Delayed delivery
Incident Report for Engagespot
Resolved
This incident has been resolved.
Posted Jun 16, 2023 - 06:15 UTC
Monitoring
Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Jun 16, 2023 - 06:00 UTC
This incident affected: API.