Notification Delivery Issue
Incident Report for Engagespot
Resolved
Incident has been resolved.
Posted May 03, 2022 - 10:11 UTC
Identified
We've identified the issue and is working on a fix.
Posted May 03, 2022 - 10:06 UTC
This incident affected: API.